Доступ к Mikrotik с динамического IP

📅 25 Фев 2016 20:30 | 👁 63 | 🕐 < 1 мин.

Столкнулся с проблемой, у пары сотрудников на работе нет возможности и желания дома подключить “белый” ip адрес, но им необходим доступ по HTTP, FTP, OpenVPN к локальной сети компании.

Шлюзом является Mikrotik RB 2011UiAS-2HnD, железка достаточно хорошая и имеет много возможностей.

Одной из возможностью, является написание скриптов управления, которые можно запускать через планировщик в нужное время.

Для решения задачи, на домашнем оборудовании сотрудников был настроен сервис ddns, каждому сотруднику было придумано dns имя и запущено.

На стороне корпоративного шлюза был написан небольшой скрипт и запущен через планировщик на выполнение раз в час.

Собственно сам скрипт:

/ip firewall address-list remove [ find where list=ddns-host ];
/ip firewall address-list add address=[ :resolve 201602corpuser1.ddns.net ] list=ddns-host comment=[:system clock get time];
/ip firewall address-list add address=[ :resolve 201602corpuser2.ddns.net ] list=ddns-host comment=[:system clock get time];

Где ddns-host – это лист динамических IP для файрвола, а 201602corpuser1.ddns.net и 201602corpuser2.ddns.net – это тут самый динамический хост.

Таким образом нам остается добавить необходимые правила в файрвол для листа ddns-host.

Поделиться

One Response to“Доступ к Mikrotik с динамического IP”

  1. Alex
    07/06/2016 at 17:22 #

    Еще можно вместо ddns.net, сделать реализацию на pdd яндекса, фактически с помощью их апи можно поднять свой ddns на своем домене.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

(Required)